Back to overview
Degraded

MFC is not loading for some users

May 15 at 05:00pm GMT+8
Affected services
OneSynergy

Resolved
May 15 at 06:20pm GMT+8

Thank you for your patience. The issue is resolved.

Created
May 15 at 05:00pm GMT+8

We are currently looking into the issue and will get back to you as soon as possible with an update. Thank you for your patience.