Back to overview
Degraded
Degraded Performance with MFC, Emails & SMS.
Sep 20, 2023 at 8:58am UTC
Resolved
Sep 20, 2023 at 10:55am UTC
The issue affecting MFC and other areas has been fixed.
Affected services
Created
Sep 20, 2023 at 8:58am UTC
We are experiencing some degraded performance with the sending of emails & SMS. MFC is similarly affected.
We are aware of the issue, and are working on restoring the affected services.
Affected services