Back to overview
Degraded
Intermittent disruption of MyInfo
Nov 22, 2023 at 5:39am UTC
Resolved
Nov 22, 2023 at 6:20am UTC
MyInfo functionality is now fully restored.
Affected services
Created
Nov 22, 2023 at 5:39am UTC
We have received notice that there may be intermittent disruptions for MyInfo retrievals. If you are experiencing difficulty retrieving data via MyInfo, please fill in the details manually.
Affected services